Softhoy » Wordpress » WordPress 3.1 usará jQuery 1.4.4 y jQuery UI 1.8.6

WordPress 3.1 usará jQuery 1.4.4 y jQuery UI 1.8.6

22 noviembre 2010

jquery wordpress

Como era de esperar, vamos con un poco de retraso con respecto al calendario de desarrollo de WordPress 3.1, ya que hace unos días que deberían de haber liberado la primera beta. Eso sí, ya se están probando varias funcionalidades en WordPress.com, aun quedan muchos tickets por resolver antes de que podamos instalar la beta completa.

Así que nos olvidamos del 15 de diciembre como fecha de salida de la release definitiva. De todas formas podemos ir preparándonos para las novedades, que esta ocasión se centran en un cambio de versiones de jQuery y jQuery UI.

WordPress 3.1 usará jQuery 1.4.4, y jQuery UI 1.8.6. Con este cambio lo primero que tienes que tener en cuenta es en comprobar que no falle ninguno de los plugins que tengas instalado por el cambio de versión. Teniendo en cuenta que el framework es usado por una cantidad más que considerable de plugins.

Si usas jquery-ui-core y widget factory, o algún plugin que dependa de widget factory deberás actualizar tu plugin y utilizar en su lugar jquery-ui-widget. Todo esto se debe a que en jQuery 1.8.x el widget factory está separado del núcleo de jQuery UI. Para ver las dependencias existentes puedes consultar wp-includes/script-loader.php.

Vía | WordPress Dev Updates

Tags: , , , ,
Artículos recomendados

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Enlaces a esta entrada

  1. Bitacoras.com 23 noviembre 2010
  2. Twitter Trackbacks for WordPress 3.1 usará jQuery 1.4.4 y jQuery UI 1.8.6 [bdebloggers.com] on Topsy.com 25 noviembre 2010

Utilizamos cookies, tanto propias como de terceros, para mejorar la navegación, nuestros servicios y recoger información estadística. Al acceder a está aceptando su instalación y uso en los términos de nuestra política de cookies. Más información